Overview
When trying to post a comment on a piece of content, like a blogpost, normal users are not able to see the "Add comment" button, while administrators can.
This article outlines the possible causes and solutions for this issue.
Diagnosis
Below you can find a screenshot of how the blog post appears for a normal user:
While this is the appearance of the same blog post for an administrator:
Solution
In most cases, this problem is generated by permission issues on the specific space.
Navigate to the space main page, and click Manage (gear icon on the top right) > Permissions:
From the permissions page, verify what is the permissions for All Registered Users:
In the above example, "All Registered Users" have "View" permission - check number (1) in the screenshot.
There are two main ways of restoring normal permissions.
The first and more straightforward option is to just reset the permissions on the space to those of the main Community, using the button "Re-establish permission inheritance to Default Space" (identified by (2) in the screenshot). Please note that if you have a structure of Spaces and Subspaces, the button will reset the permission to those of the parent Space.
The second option is to use the small edit button (3) to change the permissions for All Registered Users. This will show a dropdown, in which you will be able to select the correct permission level, for example "Contribute":
Please refer to the below table for the meaning of standard permissions level for a Space in Jive:
Space permission level | Access granted |
---|---|
Administer | Design the space layout, read and write all content types, delete (but not edit) comments, assign permissions to users and user groups, delete the space |
Moderate | Read and write all content types, edit other user content |
Create |
Read and write all content types |
Contribute | Comment on commentable content types and reply to questions and discussion threads |
View | View content |
Discuss | Read and write in discussions and questions, contribute on all other content types. This permission applies only for a space's own content. |
If the permissions are all set correctly, but still agents are not able to post comments, please open a ticket in the Jive Support Portal, and make sure to provide the screenshot of the permissions on the space as you found in the troubleshooting.
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