Overview
The user is changing the email of an unfederated or federated user but the change is not effective. The user has full admin rights, but the email changes don't persist despite getting a success message “User properties updated successfully.”
Reproduction Steps
- Navigate to Admin Console > People.
- Select an unfederated or federated user.
- Change user's email from, for example, abc@test.com to xyz@test.com
- Save changes.
- A success message is seen.
Sending an email after following the above steps goes back to abc@test.com
Environment
- Jive Interactive Intranet
- Jive Core
Root Cause
The reason is the system property skin.default.changeEmailEnabled
is set to False
. This property prevents accidental changes to email addresses.
Resolution
Set the value of the system property skin.default.changeEmailEnabled
to True
.
On-Premise customers can perform this change on their own, while Cloud and Hosted customers will need to contact us.
Note: SSO might change the federated user’s email again - so you may want to consider changing the email on the SSO side if required. This happens because the SSO Provider is assumed to have the current and correct information for a user, and when a sync happens, the SSO Provider's email information is written over the email information saved via the Jive admin console.
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