Overview
When installing Jive for Outlook and the Super Search function is enabled, the installation progress bar gets stuck in "Indexing" status.
After reviewing the logs, the following error occurs repeatedly:
System.Net.WebException: The remote server returned an error: (401) Unauthorized. at System.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult) at OffiSync.Common.Utilities.AsyncHttpRequest.OnGetResponseCompleted(IAsyncResult ar) 11:56:56,638 [9 ] ERROR [(null)] RestHandler: Failed in request [GET https://openexchange.community.xxxxxxxxx.com/__services/eapis/v1/server/time]. HandleErrors=false -> Calling callback. Response: { "error": "invalid_token", "error_description": "Invalid access token: xxxxxxx-xxxxxxxxx-xxxxxxxxxxx" }: The remote server returned an error: (401) Unauthorized.
Root Cause Analysis
The application is trying to authenticate using an invalid access token.
Diagnosis
The application attempts to authenticate using an oAuth (open authentication) token when the super search feature is enabled.
Solution
Revoke the user's oAuth token so that they would have to re-authenticate by username/password next time they log in from their desktop.
- From the Jive Admin Console, navigate to System > Settings > Extended APIs > Desktop Applications [tab].
- Under the Security section, enter the user's ID or username in the User name or ID: field.
- Click the Revoke button.
Confirmation
The page will refresh, but there will be no confirmation message. Continue with the installation and the indexing process should only last for a few minutes. You should be able to proceed to the next step of the installation process.
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