Overview
Jive administrators are able to configure custom system settings that allow the From Address and Name of these notification emails to be masked on a system-wide basis, so that users see the emails coming from a corporate email mailbox, instead of "Jive admin updates".
Please note that users in your Jive community are able to self configure email notifications, which controls what notification emails they receive for different activities that take place, such as when they are @mentioned or someone adds a comment to the content they have posted.
Diagnosis
This article is applicable if you want to change the From address and Name used in system-generated Jive notification emails. This will affect how the email looks to the end-user. In the image below, 1 identifies the Sender Name (the Display Name), and 2 identifies the sender email address.
The Solution presented below can be performed autonomously by On-Premise customers.
Hosted and Cloud customers will need to request the same actions to be performed by a Support Agent, by opening a ticket in the Jive Support Portal.
Solution
In order to complete this change you need to perform two steps:
- change the Server Admin Name and Email to what you prefer and make sense for your users
- making sure that the relevant System Properties are set to the correct values
Changing the default Server Admin Email and Name
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Navigate to Your Avatar > Admin Console
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Navigate to System >Settings > Email Server
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Enter the desired Server Admin Email (email address) and Server Admin Name (name) to the fields, then click the button to apply the configuration.
Setting the correct system properties
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Navigate to Your Avatar > Admin Console
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Navigate to System > (Management) > System Properties
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To mask the sender's From: address and replace it with the configured Server Admin Email address, change (or add) this property:
user.email.forceSystemEmailDisplay = true
Below is an example of a notification email generated from an @mention with the
user.email.forceSystemEmailDisplay
property set to true:
Note: Even when enabling this setting to force the From: address, Jive email notifications maintain the original Reply-To email address, which will be the email address of the Jive user who generated the notification event. -
To mask the sender's Name to use the configured Server Admin Name instead, change (or add) this property:
user.email.forceSystemNameDisplay = true
Below is an example of a notification email generated from an @mention with the
user.email.forceSystemNameDisplay
property also set to true:
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If both properties are enabled, then the System Settings entries will look like this:
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Click the button once each system property is altered (or added) for the changes to take effect immediately (no restart required).
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