Overview
This article describes an issue in which data cannot be extracted from recent CMR Reports, and they are:
- Stopped.
- Not updating.
- Not completed.
Also, the ETL job fails and an error message similar to the following is displayed when trying to extract data from recent CMR Reports:
Task: Group: Batch entry XX INSERT INTO jivedw_group_stage (group_id, name, description, creation_ts, modification_ts) VALUES (262449 'KZ-LM-ROLE-CUSTOMER_ACCOUNT_ADMIN-ADMIN-KZ-LM-ROLE-KZ-LM-ROLE-CUSTOMER_ACCOUNT_ADMIN-ADMIN'), ", '2019-01-30 11:43:56.619000 +00:00:00', '2019-01-30 11:43:56.641000 +00:00:00') Call getNextException to see the cause.
Environment
This issue can be experienced in Jive: Hosted Version: 9.0.1
Root Cause Analysis
This issue occurs when synced users from external systems contain group information that exceeds the 100 character limit set in the database.
Steps to Reproduce
- Log in to the desired instance.
- Open Community Manager Reports.
- Check any report. You will notice the reports are not available for recent dates.
Solution
Before making any changes to the production instance, you may need approval from management. Please refer to Support change management for further information.
The issue has been previously solved. The fix is implemented from version 9.0.2 onwards.
Workaround
- Reduce the size of the information of all user groups provisioned through an external system to less than 100 characters.
- Alter the database table to support a larger text size for reference. The following queries can be used to accomplish this task:
- ALTER TABLE jivedw_group ALTER COLUMN name TYPE varchar(255);
- ALTER TABLE jivedw_group_stage ALTER COLUMN name TYPE varchar(255);
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