Overview
You may encounter the below listed common errors while trying to test or save the changes to the Directory Server Settings in your Jive community. These errors are usually related to the invalid credentials or other LDAP sync settings.
- Error Authenticating with the Directory Server
- Error Connecting to the Directory Server
- Unknown Host Address
- Error Verifying the DN Base
Successful configuration of Directory Server Settings displays the message: Valid connection to the directory server.
For initial instructions on how to set up Directory Server LDAP sync, please refer to Configuring LDAP Server with a Jive Community article.
Prerequisites
Administrative access over your Jive instance.
Solution
Error Authenticating with the Directory Server
Root cause
Invalid credentials of the administrative account.
Resolution
- Verify that the Administrator username and password entered by you are correct.
- And ensure that the Administrator account is not locked in the directory server. A quick way to verify this is by logging into your directory server using this account.
Error Connecting to the Directory Server
Root cause
An incorrect port number is entered.
Resolution
You should check and verify that the port numbers are correctly specified. Please get in touch with your organization's Directory Server administrators for acquiring the correct settings.
Unknown Host Address
Root cause
The primary host or failover host address is either invalid or unreachable.
Resolution
- Check that the primary host and failover host Directory Server addresses are correctly entered.
- Ensure that the Directory Servers are not down.
- Since Jive needs to connect to the Directory Servers to validate the settings, you will need to ensure that these servers are accessible.
- If you are using Jive On-premise instance, please get in touch with your organization's system administrator to resolve this.
- If you are using Jive Hosted or Cloud instance, you will need to ensure that Jive's IP addresses are allowed to connect to your network.
- In case your network uses a VPN setup, you will need to get in touch with your organization's system administrator to ensure that the Directory Servers are accessible.
Error Verifying the DN Base
Root cause
The Base DN value is incorrect.
Resolution
You should check and verify that the Base DN is correctly specified. Please get in touch with your organization's Directory Server administrator for acquiring the correct settings.
Testing
If all Directory Server settings for LDAP sync are correctly configured, you will see a success message similar to the screenshot below.
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