Overview
Sometimes when you search for content in your Jive community, the results may be missing new content, @mentions do not populate properly, or the most appropriate match may not be listed at the top. This article provides assistance with fixing search index issues.
Environment
- Jive Legacy Cloud
- Jive Cloud AWS
- Jive Hosted
- Jive On-Premise
Diagnosis
This problem may manifest in a number of ways, and affect both spotlight and advanced search.
- Inconsistent results - a search now may show different results than it did a period of time ago
- No results - a search may show no matches at all when at least one is expected
- @mentions - not consistently finding the content, or unable to find them at all
- Using Filter by Tag or Filter by Action does not produce the expected results
Solution
The fix to this issue varies depending on the root cause. Below are some possible solutions:
- Check the Jive Software Status page
- Check for Issues with User Search
- Check a search index rebuild is not already running
- Check Search Service Status
- Rebuild the Content Search Index
Check the Jive Software Status page
Check the Jive Software status page to see if there is a known issue that may be affecting search performance.
Check for Issues with User (People) Search
Your issue may actually be related to User (People) rather than the Content search function. Read the article People Search Not Working As Expected or Showing Incorrect Results for more details.
Check a search index rebuild is not already running
If a search index rebuild is currently running, you will need to wait until that activity is completed before testing search results again. See the article on how to update or rebuild the content search index for more information.
Check Search Service Status
If the "Last Failed Call" in the Search Service Status (as seen in the provided image) shows a recent failure for the Query service, it may indicate a temporary issue such as timeouts or connectivity problems. Occasional failures can occur because the search endpoint is part of a shared cloud service. Most of these errors are typically temporary and can be ignored. However, if the search results are inconsistent (e.g. sometimes showing no results, sometimes showing some content but no spaces, and at other times showing both content and spaces), performing a Rolling Restart of the Jive instance is recommended to clear any potential stale states and refresh the environment.
Rebuild or Update the Content Search Index
As a last resort, you may need to update or rebuild the content search index. This is a resource-intensive procedure, and should only be conducted during a time when it will have the least impact on your user community.
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