Overview
A user is not receiving forced email notifications on news feed updates. This KB article will guide the user through the process of fixing the issue.
"Forced" in this case means that the news stream is marked for sending emails even if the user is not following the specific news stream.
Diagnosis
This error can be reproduced by following the steps mentioned below:
- Create a news stream that includes a valid user with a valid email, by using the "+" button on the News Page:
- Set up the news feed by adding some places and mark it for sending emails to users, as per the below screenshot:
Refer to the article Creating Custom Streams for more details. - Create content in the space or group that you included in the news feed.
The News stream should update and an email should be sent to the users associated with the news stream rule. If it does not happen, please proceed to the below Solution.
Solution
Clear the system and application cache and subsequently rebuild the affected news stream by following the steps given below:
- Follow the steps as listed in Clearing the System and Application Cache.
- Navigate to Admin Console > System > Settings > News > Rebuild steam:
- Select the news feed you want to rebuild from the dropdown (Email Alert, in this example):
- Click Rebuild. The stream will start the rebuilding process and you will see a message below that says Rebuilding Publication '<selected news stream name>'...
- Once the rebuild completes successfully, the message will disappear, and the page will be ready for another rebuild if needed. Be aware that news streams with a lot of content may take a long time to complete the process.
Testing
Creating new content under the affected news stream should now deliver an email notification to the users.
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