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News Streams Not Generating Email Notifications or Updates to Followers when new Content is Posted

Overview

News Streams can be set to automatically send notifications/updates through emails. If you notice that intended users are not receiving the emails or inbox notifications when following a news stream, there may be issues with the News Stream settings or backend configuration. The issue may be intermittent.

- You have the Notify Users - Email option turned on (for News Streams)

- You have the Update: Email option turned on (for Custom Streams).

 

Diagnosis

In order to get the email notifications, you need to ensure that updates through email are enabled for your News Stream first.

  • Navigate to the News page, select the affected Stream, and click on the Edit option.

    2020-10-13_20-04-46.png

  • Make sure that the Email checkbox is enabled and click on the Done button.

    2020-10-13_20-13-29.png

  • Create any content such as a Document in a Place from the affected Stream.

    Please note that the content needs to be created within a Place from the affected Stream. If you move existing content to the Place, you will not receive email notifications and that is expected product behavior.

  • If you don't receive the email notifications for the new content but are receiving other notifications then the solution in this article applies to your issue.

You should also check if the affected users' preferences are set to receive notifications from the affected news stream via email:

  1. Go to Profile Icon > Preferences > News & Stream Notifications
  2. Ensure “Email” is checked for the stream in questionmceclip0.png

 

Prerequisites

Administrative access to your Jive instance.

 

Solution

Step 1: Rebuild the News Stream

Rebuilding the News Stream forces a refresh of the configuration and can resolve most issues.

 

Step 2: Clear the Application Cache

Clear the Application Cache to ensure that none of the old caches are causing conflicts for the Streams.

You will be able to perform this step for Jive Hosted or On-premise instances. If you have a Jive Cloud instance, please contact us.

 

Step 3: Perform a Rolling Restart

If this still doesn't resolve your issue, please perform a rolling restart of your instance.

 

Testing

Created any content such as a Document in a Place from the affected Stream and it should now send a notification email.

 

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  1. Priyanka Bhotika

  2. Posted
  3. Updated

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