Overview
After an upgrade from Jive Hosted and On-Premise (HOP) from version 8 to version 9, all User Bookmarks are not working anymore.
When the user clicks on any bookmark, an Authorization error is displayed (that translates to HTTP 404 on the backend):
Diagnosis
Bookmarks are created through Actions > Bookmark on any piece of content:
After "Bookmark" is clicked, the content shows as "Bookmarked":
and it is visible in the user bookmarks, available in the User Profile > Bookmarks:
In order for this article to be applicable, the error displayed in the Overview needs to be displayed for all bookmarks created in the old version (before the upgrade).
Solution
The issue is solved starting from 9.2. A hotfix is also available for HOP 9.1, with release version 9.1.0.3.
Upgrading to 9.2 or 9.1.0.3 will solve the issue, and your bookmarks will return accessible again.
You can find the upgrade package on your MyJive Licenses portal at https://community.jivesoftware.com/apps/jive-licenses. If you do not have access, please request for the access through the Jive Support Portal.
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