Overview
This article provides the diagnosis and resolution for the couldn't ingress activity errors in the On-Premise search.
Diagnosis
Look for a message like the following, in the sbs.log:
2012-11-14 12:58:01,352 [qtp1075151505-22] ERROR com.jivesoftware.service.activity.ingress.http.endpoints.ActivityStreamIngressRestEndpoints - couldn't ingress activity! com.jivesoftware.service.ingress.ActivityStreamServiceException: API tenant:a299c6af-6710-4c35-90cc-4364133a727a-dev does not match tenant in activity:a299c6af-6710-4c35-90cc-4364133a727a - likely bug in client
As observed here, this is caused by a mismatch in the tenant id between the instance and the search node.
Resolution
To resolve this, double-check that the following system properties match what you expect in the application and EAE database, as well as on the search node logs.
jive.instanceId
jive.sbs.instance.type
jive.eae.instance.type
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