Overview
After upgrading an On-Premise instance from Jive 7 to Jive 9, and with the previous configuration of a default watermark in the videos, the following issue might occur:
In Admin Console > Video > Settings, the watermark option does not exist anymore and the watermark could persist in the videos without being able to remove it.
This article provides the solution to adjust the system property value to remove the persistent watermark post-upgrade.
Information
Environment
Jive Interactive Intranet-Hosted On-Premise 9.x
Note
The system property change requires a restart, therefore, it would be recommended doing this during the out-of-office hours.
Root Cause Analysis
The reason for not having the option for the watermark in video settings within the admin console is because, in recent Jive versions, we have transitioned from using an Adobe Flash video player to an HTML5 Video player (JWPlayer).
The new HTML5 player does not support an overlay watermark.
That being said, in this case, the watermark persisted from the migration progress as seen in a system property set like this:
__jive.watermark.id = 123456
Solution
To remove the persistent watermark, it is required to set the mentioned property within the Admin Console > System > Management > System Properties page to the following value:
__jive.watermark.id = 0
Comments
0 comments
Article is closed for comments.