Overview
When multiple users are actively working on the same document through Jive for Office add-in and one of the users publishes a new version of the document, the other users receive a message similar to the following when trying to save and publish their changes:
User 2 has published a new version of this document (v2). However, your collaborator did not use Jive for Office, and we can't automatically merge the changes.
The username and the document version number in the error message above are only for representation and may be different for your instance.
Diagnosis
Steps to reproduce
- Connect two different installations of Jive for Office with two different users connected to the same Jive instance. We will call the users User 1 and User 2 for this example.
- Create or open an existing document that is accessible to both users.
- Make changes to the document and publish it as User 1. Ensure that User 2 also has the document opened at the same time.
- Make changes to the document as User 2 and try to publish it.
Observed behavior
Document publishing will fail and User 2 will see an error stating:
User 2 has published a new version of this document (v2). However, your collaborator did not use Jive for Office, and we can't automatically merge the changes.
Expected behavior
User 2 should be presented with the Merge and review option.
Solution
This bug was fixed in the Jive for Office version 30.7.69 with the issue key JVFINTG-3986. You can update your Jive for Office installation through the automatic update or by following the instructions in Installing and Configuring Jive for Office For End Users.
Testing
After updating Jive for Office add-in, multiple users should be able to edit the documents simultaneously. And if there is a merge conflict in the document, the user will be prompted with the Merge and review option while publishing.
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