Overview
After the instance is upgraded to the 9.0.6 version, the doc converter fails to convert the uploaded documents for HTML5 preview and displays the following error message:
We're sorry! We were unable to convert this document for viewing.
Click to try converting the document again.
This article analyzes the cause of the error and provides a quick fix to resolve the error message.
Information
Environment
Jive Interactive Intranet-Jive Core
On-Premise only
Steps to Reproduce
- Upgrade from 9.0.4 to 9.0.5 on SLES_11.
- Install the PDF2SWF package.
- Restart the doc converter and initiate a Full Conversion Test from the Admin console.
Current Behavior
Full Conversion Test on Admin console fails with the following error:
Error: office2pdf failed with unhandled exception: Converting file ca-OfficeToPDFTest###...doc for step office2pdf and page 0 encountered an error.
Expected Behavior
The Full Conversion Test on the Admin console should be a success and the HTML5 preview gets generated for PDF files that are uploaded to the Jive instance.
Diagnosis
- Verify the logs from the doc converter node to confirm if the below error is observed:
ERROR impl.OpenOfficeManagerImpl - OpenOffice on port 8824 logged an error: /usr/local/jive/opt/libreoffice5.3/program/soffice.bin: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /usr/local/jive/lib/libfreetype.so.6)
- This error is caused by the GNU C Library version 2.14 that was missing from the Jive RPM.
Solution
- Ensure that the customer is downloading the latest RPM from the Aurea license page which includes the missing library.
NOTE: The license link mentioned above will take the customers to the respective license page and will display their respective license details as per their login credentials. Otherwise, you are expected to see the Aurea Sales contact details here.
The fix id for this issue is JVHOPLE-2714 for more details.
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