Overview
On the Activity Engine page, EAE's total depth does not stop increasing. This is not a good sign as it means that the queue is filling up with items that are not being shredded as activity comes in.
To learn more about this issue, read through the following sections.
Information
To have a better understanding of this issue, read about the Shredder Queue in the article Activity Engine Processing Queues.
Troubleshooting
Root Cause
Upon collecting the EAE logs, the following exception occurs:
ERROR [] com.jivesoftware.eae.service.queue.ExceptionDrivenThrottle - Recommender Consumer Throttle - Throttling for 60000 ms on exception: com.jivesoftware.service.reco.http.client.InvalidExecutionException: send exception: dev-reco-ingress.jiveland.com
This means that the recommender service is attempting to connect to an internal development server: "dev-reco-ingress.jiveland.com" which is not the correct one.
Resolution
- Using the Magic Query Tool, confirm the
instanceType
value by running the following query on the EAE database.SELECT * FROM jiveInstanceProperty WHERE propname = 'instanceType';
The value should either be
2
for UAT, or3
for production for the recommender service to work. If not, proceed to the next step. - Update the value of the system property
jive.eae.instance.type
to the correct one.- Configure the system properties and set the value of
jive.eae.instance.type
to2
for UAT, or3
for production. - If you do not find this system property, please add it and set its value accordingly.
- Configure the system properties and set the value of
- Restart the instance.
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