Overview
Invalid object issues occur when posting status updates containing links, # tags or @mentions with the following red bar error:
Your content could not be saved due to an error. You may have been logged out. If this problem persists please contact your system administrator. Click here to refresh this page.
Looking at HAR (HTTP Archive) logs, the user sees a 400 Bad Request Error response with the following information:
{"error":{"code":4001,"message":"WallEntry Message contains more than 420 characters."}}
Diagnosis
Consider the following reproduction steps and behavior to check if the defect is present in your instance:
- Steps to reproduce:
- Post a status update by clicking the Pencil icon in top right corner, and selecting "Status Update":
- Within the status update @mention a combination of users, places, and content items, but keep the message under 420 characters total:
- Click "Post"
- Post a status update by clicking the Pencil icon in top right corner, and selecting "Status Update":
- Current behavior:
- The following red bar error will be thrown:
Your content could not be saved due to an error. You may have been logged out. If this problem persists please contact your system administrator. Click here to refresh this page.
- Looking at HAR (HTTP Archive) the user sees a 400 Bad Request Error response with the following information:
{"error":{"code":4001,"message":"WallEntry Message contains more than 420 characters."}} - Please note that these steps will not reproduce in Jive Hosted versions 9.0.6 and higher.
- The following red bar error will be thrown:
- Expected behavior:
- Status updates under 420 characters in size should post fine no matter how many @ mentions, links or #tags are used.
Solution
This is a known defect that was fixed in Jive Hosted release 9.0.6. Please update to 9.0.6 or higher version to resolve this issue.
For Jive Hosted release 9.0.5, a workaround exists: you can set the system property:
__jive.wallentry.character.max = 2000
This will allow for more characters to be stored and will prevent the message to be displayed.
In order to set this system property, if you are an On-Premise customer, please refer to Configuring System Properties (On-Premise). If you have a Hosted instance, please open a ticket into the Jive Support Portal.
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