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Error: 'Only federated users can login via SSO'

Overview

Users might be not able to log in via SSO (Single sign-on), with the following error appearing in the logs:

com.jivesoftware.community.aaa.sso.SSOAuthenticationException: Only federated users can login via SSO. Federate user 'ImmutableUser{email='xxxx@xxxxx.com', name='Xxxx Xxxx'...} to enable login

This article provides the Root Cause Analysis and steps to resolve this issue.

Environment

Jive Interactive Intranet-Jive Core

Root Cause Analysis

Diagnosis

This error indicates that the user is not Federated, thus logging in via SSO is not possible.

Solution

Federate the affected user.

Steps

  1. Navigate to Admin Console >People > User Search.
  2. Search the user whose User ID needs to be Federated.
  3. Click on the Federate link. 

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  1. Priyanka Bhotika

  2. Posted
  3. Updated

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